Перейти к содержимому

Фото
- - - - -

вместо руских букв знаки вопроса


  • Вы не можете создать новую тему
  • Please log in to reply
8 ответов в этой теме

#1 Alko

Alko
  • Постоялец
  • 1 709 сообщений

Отправлено 22 Август 2008 - 19:35

заливаю базу через phpmyadmin (zone.ee), база в cp1251, а на сайте русский текст который береться из базы в виде знаков вопроса. Что делать ? в phpmyadmin тоже поставил сравнение cp1251. но без результатно. хотя хост поддерживает cp1251.

Сообщение изменено: Valko (22 Август 2008 - 21:36 )

  • 0

#2 DTprog

DTprog
  • Пользователь
  • 80 сообщений
  • Откуда:Tartu

Отправлено 23 Август 2008 - 00:14

Такое у меня было, когда я в базу данных русский текст не SQL запросом вставлял, а через меню записи "Изменить" в phpmyadmin.
  • 0
Когда усилия науки прольют везде елей и мед,
По любопытству иль со скуки все это кто-нибудь взорвет.

#3 ParadoxL

ParadoxL
  • Постоялец
  • 4 756 сообщений
  • Откуда:Edinburg

Отправлено 23 Август 2008 - 01:13

добавь в phpadmin чтобы в заголовке HTML формы с TEXTAREA, через которую ты забиваешь SQL было
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

И будет тебе счатье ... просто бравзер урезает >127
  • 0
Victoria nulla est, Quam quae confessos animo quoque subjugat hostes ...
Верю в смерть после жизни, любовь после секса и в крем после бритья ...

#4 .NET

.NET
  • Постоялец
  • 3 511 сообщений

Отправлено 24 Август 2008 - 18:08

<?php
mysql_connect(blablabla);
///...

mysql_query("SET character_set_client='cp1251' ");
mysql_query("SET character_set_results='cp1251' ");
mysql_query("SET character_set_connection='cp1251' ");
  • 0

#5 Alko

Alko
  • Постоялец
  • 1 709 сообщений

Отправлено 24 Август 2008 - 19:12

ну это все я и до ваших постов делал, только это ничего не помогает. я все таки сделал, но подругому. Но теперь пробелма следущая, если добавлять инфо через форму сайта, то в итоге будут опять знаки вопроса, а если через пхпмуадмин то все ок, вот в чем вопрос.
  • 0

#6 .NET

.NET
  • Постоялец
  • 3 511 сообщений

Отправлено 24 Август 2008 - 19:43

Valko, Мучай хостера раз эти, почти 100% решающие проблему советы, не помогли )
  • 0

#7 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 25 Август 2008 - 09:58

Valko, у тебя дамп базы? На zone.ee MySQL 5й версии, возможно, у тебя старый дамп и в нём не указаны кодировки для полей таблиц.
  • 0

#8 Alko

Alko
  • Постоялец
  • 1 709 сообщений

Отправлено 25 Август 2008 - 16:51

указаны
  • 0

#9 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 25 Август 2008 - 17:09

В PHPMyAdmin на 1й странице сопоставление соединения MySQL CP-1251 ?
  • 0