Перейти к содержимому

Фото
- - - - -

чудеса Java


  • Вы не можете создать новую тему
  • Please log in to reply
Пока никто не отвечал в этой теме...

#1 _kosha

_kosha
  • Новобранец
  • 10 сообщений
  • Откуда:Tallinn

Отправлено 09 Сентябрь 2005 - 15:35

JSP+JSF

Всё уже работает, но я не понимаю ПОЧЕМУ такое работает:
<link href="<%=sPath%>//css/general.css" rel="stylesheet" type="text/css" media="screen" />

а такое
<link href="<%=sPath%>/css/general.css" rel="stylesheet" type="text/css" media="screen" />
не работает! :unsure:

Одним слэшем меньше, в System.out выводил правильный линк, по которому из браузера открывался соответствующий css, но работать начинает только при добавлении ещё одного "/";

Чудеса, блин :x

Добавлено в [mergetime]1126272930[/mergetime]

а в source результата что?

Работающий вариант:
</script>
<link media="screen" type="text/css" rel="stylesheet" href="http://172.27.107.84:8993/RHR2-ViewController-context-root//css/general.css">
</link>
<link media="screen" type="text/css" rel="stylesheet" href="http://172.27.107.84:8993/RHR2-ViewController-context-root//css/menu.css">

В неработающем, соответственно, на слэш меньше.
Обнаружил что url
http://172.27.107.84:8993/RHR2-ViewController-context-root//css/menu.css
и
http://172.27.107.84:8993/RHR2-ViewController-context-root/css/menu.css
Указывают на 2 разных menu.css файла. Но у меня только один menu.css файл в каталоге. Уею и плачу, дорогая редакция :P

Запускаю с "Embedded OC4J Server" из-под JDeveloper 10.1.3.

Сообщение изменено: _kosha (09 Сентябрь 2005 - 15:20 )

  • 0