Перейти к содержимому

Фото
- - - - -

Google Chrome и Ubuntu(9.04)/Debian(6)


  • Вы не можете создать новую тему
  • Please log in to reply
5 ответов в этой теме

#1 POPEYE

POPEYE

    Стебно таблетку оторвал... :-) | ptrd.narod.ru

  • Постоялец
  • 4 818 сообщений

Отправлено 01 Июль 2013 - 17:46

Вот интересно есть у меня Ubuntu 9.04 в ней стоит Chrome, скачанный когда-то давно 5.0.375.55 (r47796).

Попытки установить такую же версию Chromium (старые версии хрома, похоже, нигде не хранятся) на такой же ОС (да и на той же самой если запустить инсталлятор пакетов), вызывают ошибку зависимостей как минимум с библиотекой libasound2. Даже если принудительно проинсталлировать, он все-равно не запускается, ссылаясь, что нет каких-то c++ библиотек итд.

 

В Debian уже в своих репозиториях есть Chromium, но инсталлится без проблем только 6-ой.

 

Естественно возникают два вопроса:

Как фактически одна и та же версия браузера может подходить и не подходить?

На что рассчитаны все deb архивы Chromium выше 6? Неужели на Debian 7, которой нет и 2-х месяцев?

 

П.С. Пока единственный браузер, да и вообще софт, из того, что я видел, который в линуксе можно обновлять фактически независимо от версии ОС - это Opera.


Сообщение изменено: POPEYE (01 Июль 2013 - 17:49 )

  • 0
I'm POPEYE The Sailor man

#2 DimKin

DimKin

    Говорил я этому балбесу - купи валенки... А он что? ...

  • S-Модератор
  • 25 766 сообщений
  • Откуда:Из Города Разбитых Дорог...

Отправлено 01 Июль 2013 - 18:16

а можно глупый вопрос - а смысл всех этих действий? unknow.gif


  • 0

Тут могла быть ваша реклама :-)

А вообще подписи - зло


#3 Demetrio

Demetrio

    uid=0(root)

  • Админ
  • 18 649 сообщений
  • Откуда:Tallinn

Отправлено 01 Июль 2013 - 18:20

Неужели на Debian 7, которой нет и 2-х месяцев?

Нет.


Смотри через ldd на бинарник хромиума чего ему не хватает.

может, найдешь недостающее..


а вообще эта некрофилия не очень понятна :)

хочешь сидеть на древней системе - будь готов что свежий софт из пакетов не поставишь.


  • 1

#4 POPEYE

POPEYE

    Стебно таблетку оторвал... :-) | ptrd.narod.ru

  • Постоялец
  • 4 818 сообщений

Отправлено 01 Июль 2013 - 18:49

 

хочешь сидеть на древней системе - будь готов что свежий софт из пакетов не поставишь.

Так он и старый, даже такой же как сейчас, по номеру версии, не ставит.


  • 0
I'm POPEYE The Sailor man

#5 Demetrio

Demetrio

    uid=0(root)

  • Админ
  • 18 649 сообщений
  • Откуда:Tallinn

Отправлено 01 Июль 2013 - 18:54

Откуда ты его берешь чтобы ставить?
  • 0

#6 Sergio

Sergio
  • Постоялец
  • 2 987 сообщений

Отправлено 01 Июль 2013 - 20:24

Demetrio правильно говорит, смотри, каких либ не хватает с помощью ldd.

Потом скачивай их все и распаковывай их в каталог Хрома. Чтобы файлы .so лежали в его корневом каталоге (/opt/google/chrome у Хрома по дефолту, у Хромиума может быть отличается).

Его скрипт запуска вроде бы сам модифицирует LD_LIBRARY_PATH, так что в первую очередь должны загрузиться либы, которые лежат  в его каталоге.


  • 0