Перейти к содержимому

Фото
- - - - -

Проблема с .htaccess


  • Вы не можете создать новую тему
  • Please log in to reply
10 ответов в этой теме

#1 Mitjay

Mitjay
  • Пользователь
  • 38 сообщений
  • Откуда:Tallinn

Отправлено 12 Январь 2006 - 16:07

Создал фаил htaccess:
AuthType Basic
AuthName "Only for administration!"
AuthUserFile /Project/admin/.htpasswd
require user admin

создал .htpasswd и юзера admin c поролем:
htpasswd -cm .htpasswd admin

при переходе в папку admin из браузера, появляется окно авторизации. Ввожу пороль, а он предлогает ввести его ещё, ещё, ещё. А потом:
Authorization Required
This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

Причем такая петрушка как на локале, так и на хосте. Может чего с путями не то.
  • 0

#2 Контрафхтагн

Контрафхтагн

    но вот

  • Постоялец
  • 2 565 сообщений

Отправлено 12 Январь 2006 - 16:11

Не помню точно, но может быть пароль админа задаёшь неверно, вроде пробела, принадлежащего паролю?
Попробуй -c сделать с введением пароля ручками, тогда он введётся точно.
  • 0

#3 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 12 Январь 2006 - 16:18

AuthUserFile /Project/admin/.htpasswd

Тут должен быть абсолютный путь! Т.е. Apache будет искать .htpasswd относительно корня сервера :) Я не тестил, поддерживаются ли относительные пути, но вот тебе 2 варианта:

1) убери слеш перед Project
2) пропиши полный путь к файлу. Например, /home/username/public_html/Project/admin/.htpasswd (это лишь пример)

Сообщение изменено: Setor (12 Январь 2006 - 16:36 )

  • 0

#4 Mitjay

Mitjay
  • Пользователь
  • 38 сообщений
  • Откуда:Tallinn

Отправлено 12 Январь 2006 - 16:27

Я немного парюсь, что такое - абсолютный путь от корня сервера. Именно так надо прописать.
  • 0

#5 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 12 Январь 2006 - 16:35

В этой директиве должен быть абсолютный путь от корня сервера. Я немного неправильно выразился в прошлом посте. Решение проблемы я тебе уже написал.

Абсолютный путь - это путь относительно корня сервера
Относительный путь - это путь относительно какого-то каталога
  • 0

#6 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 13 Январь 2006 - 01:00

3. В .htaccess пишу:  AuthUserFile  c:/documents and settings/.../.../my
html/MetallProject/admin/.htpasswd - не работает. Пишет: Internal Server Error

Ещё бы... То, что ты написал - полная фигня. Разберись с местоположением DocumentRoot! И если в строке пробелы, попробуй взять строку в кавычки и я не понимаю, зачем ты в пути указываешь "/.../.../" !!!
  • 0

#7 уррф

уррф

    ушол

  • Постоялец
  • 5 330 сообщений

Отправлено 13 Январь 2006 - 01:04

../ это же возврат в предыдущую папку
камон, уже не можете указать путь полный к файлу с паролем ?
бросайте комп нафиг, это не для вас :)
  • 0

#8 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 13 Январь 2006 - 01:11

Я только что проверил, там должен быть ИМЕННО абсолютный путь! И если в этом пути встречаются пробелы, то его нужно взять в кавычки, иначе будет Internal Server Error. Это окончательный ответ.
  • 0

#9 уррф

уррф

    ушол

  • Постоялец
  • 5 330 сообщений

Отправлено 13 Январь 2006 - 01:13

можно и не абсолютный, а относительно рут директории апача
если htaccess там
:) если вне - то да, абсолютный
  • 0

#10 Setor

Setor
  • Постоялец
  • 1 890 сообщений
  • Откуда:Эстония, Таллин

Отправлено 13 Январь 2006 - 01:26

Но такое бывает очень редко, особенно, на shared хостинге) Если только на localhost ;)
  • 0

#11 Mitjay

Mitjay
  • Пользователь
  • 38 сообщений
  • Откуда:Tallinn

Отправлено 13 Январь 2006 - 01:56

да это я для сокращения написал /.../.../...,
Cпасибо Cетор персональное тебе, заBTра попробую, сейчас я на работе.
Всё О.К.

Сообщение изменено: Mitjay (04 Февраль 2006 - 11:50 )

  • 0