Перейти к содержимому

Фото
- - - - -

Cisco: перенос конфига с 851-ой на 806-ую и pptp. WTF?


  • Вы не можете создать новую тему
  • Please log in to reply
18 ответов в этой теме

#1 erik swift

erik swift
  • Пользователь
  • 134 сообщений
  • Откуда:Москва

Отправлено 13 Февраль 2007 - 20:51

Впервые в жизни такое...
Вот кусок рабочего конфига с 851-ой:

...
username tester password 0 tester
aaa new-model
!
aaa authentication ppp default local
aaa session-id common
ip subnet-zero
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
!
!
!
interface Ethernet0
ip address 192.168.50.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface Ethernet1
ip address xxx.xxx.xxx.xxx 255.255.255.248
ip nat outside
!
interface Virtual-Template1
ip unnumbered Ethernet1
peer default ip address pool test
no keepalive
ppp authentication pap chap ms-chap
!
ip local pool vpn 192.168.200.1 192.168.200.254
ip nat inside source list 1 interface Ethernet1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 yyy.yyy.yyy.yyy
no ip http server
!
!
access-list 1 permit 192.168.50.0 0.0.0.255
...

При переносе конфига на 806-ую перестает проходить аудентификация пользователей через PAP/CHAP на pptp...

#sh vpdn выдает:
%No active L2TP tunnels
%No active L2F tunnels
PPTP Tunnel and Session Information Total tunnels 1 sessions 1
LocID Remote Name State Remote Address Port Sessions VPDN Group
2 estabd 212.7.22.178 64979 1 1
LocID RemID TunID Intf Username State Last Chg Uniq ID
2 8 2 estabd 00:00:18 1
%No active PPPoE tunnels

Клиент отваливается с 619-ой ошибкой...

Было подозрение что оверлоад NATа занимает порт 1723, но его отключение не дало никакого результата.

Стыдно мне должно быть, но может быть я после нескольких бессонных ночей явно туплю?

Сообщение изменено: erik swift (13 Февраль 2007 - 20:51 )

  • 0

#2 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 13 Февраль 2007 - 21:01

А чего пулы разные?

peer default ip address pool test

ip local pool vpn 192.168.200.1 192.168.200.254
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#3 erik swift

erik swift
  • Пользователь
  • 134 сообщений
  • Откуда:Москва

Отправлено 13 Февраль 2007 - 21:08

А чего пулы разные?

peer default ip address pool test

ip local pool vpn 192.168.200.1 192.168.200.254

Это локальный косяк, в оригинале там есть еще и пул test

Сообщение изменено: erik swift (13 Февраль 2007 - 21:10 )

  • 0

#4 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 13 Февраль 2007 - 21:16

Попробуй добавить ppp encrypt на темплейт.

Ну и дебаг фттыкать остаётся только. Провайдер точно пускает?
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#5 erik swift

erik swift
  • Пользователь
  • 134 сообщений
  • Откуда:Москва

Отправлено 13 Февраль 2007 - 21:23

Попробуй добавить ppp encrypt на темплейт.

Ну и дебаг фттыкать остаётся только. Провайдер точно пускает?

Да, сейчас кофейку заварю и пойду фтыкать.
Провайдер пускает точно.
  • 0

#6 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 13 Февраль 2007 - 21:48

А тут его только и ффтыкать. Может банально юзверь стучится с той же подсети, в которую он стучится. Сам на такое напарывался пару раз.
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#7 erik swift

erik swift
  • Пользователь
  • 134 сообщений
  • Откуда:Москва

Отправлено 13 Февраль 2007 - 22:27

Нет, клиенты точно стучатся снаружи.
В общем пока туплю, в какую сторону копать не вижу.
Зато выяснил что если циску прикрутить к радиусу, авторизация тоже не проходит.
  • 0

#8 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 13 Февраль 2007 - 22:31

Да дебажить и смотреть, чего происходит.

Можно ещё конечно попробовать IOS сменить. Пёс его знает правда, если что под такое старьё.

Я когда про подсеть писал, миел в виду, что стучиться юзверь из дома, находясь в сети, например 192.168.1.х в сеть 192.168.1.х.
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#9 erik swift

erik swift
  • Пользователь
  • 134 сообщений
  • Откуда:Москва

Отправлено 13 Февраль 2007 - 22:36

Да дебажить и смотреть, чего происходит.

Можно ещё конечно попробовать IOS сменить. Пёс его знает правда, если что под такое старьё.

Я когда про подсеть писал, миел в виду, что стучиться юзверь из дома, находясь в сети, например 192.168.1.х в сеть 192.168.1.х.

Про подсети тоже исключено... там народ с белыми адресами. IOS тут врядли поможет сменить, хотя хз... более плотно буду завтра разбираться, сегодня уже сил нет. Если интересно, когда решу, выложу тут солюшн.

Upd: нашел свою проблему: http://www.parkansky...orials/pptp.htm
  • 0

#10 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 13 Февраль 2007 - 22:47

Интересно-интересно. У нас народ любит с всякие 80х и 82х использовать. Есть фанаты. Корпус им нравится, что ли.

Но я бы вообще дебаг бы поднимал - надо смотреть, на чём затыкается. А то лучший дебагинг из всех, что есть, не использовать - это грех.

Upd: нашел свою проблему: http://www.parkansky...orials/pptp.htm


Ну круто конечно они её решать предлагают.

Типа поднимите aaa authorization, поднимите ppp encrypt про который я говорил, и выдают мысль на тему - "а оно вам надо?" :)
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#11 SevenUp

SevenUp
  • Пользователь
  • 12 сообщений

Отправлено 20 Февраль 2007 - 23:26

А как насчёт конфига с кабельного модема ?
  • 0

#12 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 20 Февраль 2007 - 23:30

Какого модема? Cisco uBR 90x?

В общем случае опшн файлы хранятся на отдельном сервере, по сему их перенос достаточно трудно себе представить. Да и как бы незачем особо - провайдер должен зарегестрировать у себя модем, так или иначе и соответственно выдать модему определённый файл опций (конфигурацию). Что может помешать провайдеру выдать модему файл, идентичный файлу другого модема - непонятно.

Сообщение изменено: IP Unnumbered (20 Февраль 2007 - 23:34 )

  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#13 SevenUp

SevenUp
  • Пользователь
  • 12 сообщений

Отправлено 23 Февраль 2007 - 00:16

Идея в том чтобы создать на компе тфтп сервер и самому закачивать настройки в свой модем. Надо для того чтобы дорогой нет в дешовый превратить..тока проблемка есть , неумею ручками етот конфиг перехватывать (((..мож кто поможет.
а чкть не забыл ..модем в аренде от стармана Сцыентик атланта Веб Стар.
  • 0

#14 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 26 Февраль 2007 - 14:01

SevenUp

Гражданин, а вы не задумывались над тем, что на этом форуме могут пребывать администраторы таких фирм как Старман, СТВ/Инфонет и т.д. ? И понимаете ли вы значения слов "прецендент" и "показательная порка"?

Да, такой трюк можете даже не пытаться провернуть. Поверьте мне, uBRы далеко не дураки настраивают и не менее глупые люди с ними работают.
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#15 Demetrio

Demetrio

    uid=0(root)

  • Админ
  • 18 649 сообщений
  • Откуда:Tallinn

Отправлено 26 Февраль 2007 - 14:12

IP Unnumbered, от аффтара: https://forum.ee/t73491/

:D
  • 0

#16 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 26 Февраль 2007 - 14:13

Demetrio

Сцылко битое, не кажет :(
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#17 Demetrio

Demetrio

    uid=0(root)

  • Админ
  • 18 649 сообщений
  • Откуда:Tallinn

Отправлено 26 Февраль 2007 - 14:15

Продам пороли от www.mail.ru, пароли на мылных ящиках

SevenUp
post Feb 23 2007, 00:10

Могу помоч узнать пасс от мылного ящика вашего товарища который регулярно проверяет почту.
С вас @ c меня пасс . Стоимость услуги 500 еек.


хацкер )
  • 0

#18 IP Unnumbered

IP Unnumbered

    Lifeguard of the Internet

  • Постоялец
  • 1 448 сообщений

Отправлено 26 Февраль 2007 - 14:20

О как! Крут чувак. Ну ладно SevenUp, тогда могу помочь получить скорость до 15 Мбит. С тебя $$, с нас скорость.
  • 0
Знание некоторых принципов освобождает от необходимости знать многие факты.

Arbeit macht frei

#19 Padalever

Padalever
  • Пользователь
  • 77 сообщений

Отправлено 26 Февраль 2007 - 21:49

SevenUp,
Старая тема, когда ещё я учился в ТТУ, инфотехнологи с Нарвы занимались взломом mail.ru за бутылку водки, а у тебя целых 500 крон услуга стоит.
Прошли те времена, когда mail.ru взламывали за принесённую ИТ-шникам бутылку водки в студенческую общагу...
  • 0